What’s Vulnerable › Vulnerabilities

CVE-2015-0242

Description

Stack-based buffer overflow in the *printf function implementations in PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1, when running on a Windows system, allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via a floating point number with a large precision, as demonstrated by using the to_char function.

Affected products

How to fix

Upgrade to a fixed version: PostgreSQL 9.0.19, 9.1.15, 9.2.10, 9.3.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-0242 or the next vulnerability affects your stack