What’s Vulnerable › Vulnerabilities

CVE-2015-0259

Description

OpenStack Compute (Nova) before 2014.1.4, 2014.2.x before 2014.2.3, and kilo before kilo-3 does not validate the origin of websocket requests, which allows remote attackers to hijack the authentication of users for access to consoles via a crafted webpage.

Affected products

How to fix

Upgrade to a fixed version: OpenStack Nova 2014.1.4, 2014.2.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-0259 or the next vulnerability affects your stack