What’s Vulnerable › Vulnerabilities
CVE-2015-0274
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-03-16 · updated 2026-06-17
- Weakness: CWE-19
Description
The XFS implementation in the Linux kernel before 3.15 improperly uses an old size value during remote attribute replacement, which allows local users to cause a denial of service (transaction overrun and data corruption) or possibly gain privileges by leveraging XFS filesystem access.
Affected products
- Linux kernel: from 3.11 before 3.15 — fixed in 3.15
How to fix
Upgrade to a fixed version: Linux kernel 3.15. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=8275cdd0e7ac550dcce2b3ef6d2fb3b808c1ae59
- http://rhn.redhat.com/errata/RHSA-2015-0290.html
- http://rhn.redhat.com/errata/RHSA-2015-0694.html
- http://www.securitytracker.com/id/1031853
- http://www.ubuntu.com/usn/USN-2543-1
- http://www.ubuntu.com/usn/USN-2544-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1195248
- https://github.com/torvalds/linux/commit/8275cdd0e7ac550dcce2b3ef6d2fb3b808c1ae59
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=8275cdd0e7ac550dcce2b3ef6d2fb3b808c1ae59
- http://rhn.redhat.com/errata/RHSA-2015-0290.html
- http://rhn.redhat.com/errata/RHSA-2015-0694.html
- http://www.securitytracker.com/id/1031853
Get alerted when CVE-2015-0274 or the next vulnerability affects your stack