What’s Vulnerable › Vulnerabilities
CVE-2015-0278
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-05-18 · updated 2026-06-17
- Weakness: CWE-273
Description
libuv before 0.10.34 does not properly drop group privileges, which allows context-dependent attackers to gain privileges via unspecified vectors.
Affected products
- Fedoraproject Fedora: 21
- Libuv Project Libuv: through 0.10.33
- Node.js: before 0.10.37 — fixed in 0.10.37
How to fix
Upgrade to a fixed version: Node.js 0.10.37. Check the vendor advisory for mitigations.
References
- http://advisories.mageia.org/MGASA-2015-0186.html
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:228
- https://github.com/libuv/libuv/commit/66ab38918c911bcff025562cf06237d7fedaba0c
- https://github.com/libuv/libuv/pull/215
- https://groups.google.com/forum/#%21msg/libuv/0JZxwLMtsMI/jraczskYWWQJ
- https://lists.fedoraproject.org/pipermail/package-announce/2015-February/150526.html
- https://security.gentoo.org/glsa/201611-10
- http://advisories.mageia.org/MGASA-2015-0186.html
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:228
- https://github.com/libuv/libuv/commit/66ab38918c911bcff025562cf06237d7fedaba0c
- https://github.com/libuv/libuv/pull/215
- https://groups.google.com/forum/#%21msg/libuv/0JZxwLMtsMI/jraczskYWWQJ
Get alerted when CVE-2015-0278 or the next vulnerability affects your stack