What’s Vulnerable › Vulnerabilities
CVE-2015-0294
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-27 · updated 2026-06-17
- Weakness: CWE-295
Description
GnuTLS before 3.3.13 does not validate that the signature algorithms match when importing a certificate.
Affected products
- Debian Linux: 7.0
- [UNKNOWN] gnutls: before 3.3.13 — fixed in 3.3.13
- Red Hat Enterprise Linux: 5.0, 7.0
How to fix
Upgrade to a fixed version: [UNKNOWN] gnutls 3.3.13. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2015/dsa-3191
- https://bugzilla.redhat.com/show_bug.cgi?id=1196323
- https://gitlab.com/gnutls/gnutls/commit/6e76e9b9fa845b76b0b9a45f05f4b54a052578ff
- http://www.debian.org/security/2015/dsa-3191
- https://bugzilla.redhat.com/show_bug.cgi?id=1196323
- https://gitlab.com/gnutls/gnutls/commit/6e76e9b9fa845b76b0b9a45f05f4b54a052578ff
Get alerted when CVE-2015-0294 or the next vulnerability affects your stack