What’s Vulnerable › Vulnerabilities
CVE-2015-0310: Adobe Flash Player ASLR Bypass Vulnerability
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: yes — in CISA KEV since 2022-05-25
- EPSS: 15.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-01-23 · updated 2026-06-17
- Weakness: CWE-200
Description
Adobe Flash Player before 13.0.0.262 and 14.x through 16.x before 16.0.0.287 on Windows and OS X and before 11.2.202.438 on Linux does not properly restrict discovery of memory addresses, which allows attackers to bypass the ASLR protection mechanism on Windows, and have an unspecified impact on other platforms, via unknown vectors, as exploited in the wild in January 2015.
Affected products
- Adobe Flash Player 24.0.0.186 and earlier.: before 11.2.202.438; before 13.0.0.262; from 14.0 before 16.0.0.287 — fixed in 11.2.202.438, 13.0.0.262, 16.0.0.287
How to fix
Upgrade to a fixed version: Adobe Flash Player 24.0.0.186 and earlier. 11.2.202.438, 13.0.0.262, 16.0.0.287. Check the vendor advisory for mitigations.
References
- http://helpx.adobe.com/security/products/flash-player/apsb15-02.html
- http://secunia.com/advisories/62452
- http://secunia.com/advisories/62601
- http://secunia.com/advisories/62660
- http://secunia.com/advisories/62740
- http://security.gentoo.org/glsa/glsa-201502-02.xml
- http://www.securityfocus.com/bid/72261
- http://www.securitytracker.com/id/1031609
- http://helpx.adobe.com/security/products/flash-player/apsb15-02.html
- http://secunia.com/advisories/62452
- http://secunia.com/advisories/62601
- http://secunia.com/advisories/62660
Get alerted when CVE-2015-0310 or the next vulnerability affects your stack