What’s Vulnerable › Vulnerabilities
CVE-2015-0536
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-08-20 · updated 2026-06-17
Description
EMC RSA BSAFE Micro Edition Suite (MES) 4.0.x before 4.0.8 and 4.1.x before 4.1.3 and RSA BSAFE SSL-C 2.8.9 and earlier, when client authentication and an ephemeral Diffie-Hellman ciphersuite are enabled, allow remote attackers to cause a denial of service (daemon crash) via a ClientKeyExchange message with a length of zero, a similar issue to CVE-2015-1787.
Affected products
- Dell Bsafe: from 4.0.0 before 4.0.8; from 4.1.0 before 4.1.3 — fixed in 4.0.8, 4.1.3
- Dell Bsafe Ssl-C: through 2.8.9
How to fix
Upgrade to a fixed version: Dell Bsafe 4.0.8, 4.1.3. Check the vendor advisory for mitigations.
References
- http://seclists.org/bugtraq/2015/Aug/84
- http://www.securityfocus.com/bid/76377
- http://seclists.org/bugtraq/2015/Aug/84
- http://www.securityfocus.com/bid/76377
Get alerted when CVE-2015-0536 or the next vulnerability affects your stack