What’s Vulnerable › Vulnerabilities
CVE-2015-0837
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-29 · updated 2026-06-17
- Weakness: CWE-203
Description
The mpi_powm function in Libgcrypt before 1.6.3 and GnuPG before 1.4.19 allows attackers to obtain sensitive information by leveraging timing differences when accessing a pre-computed table during modular exponentiation, related to a "Last-Level Cache Side-Channel Attack."
Affected products
- Debian Linux: 7.0, 8.0
- GnuPG: before 1.4.19 — fixed in 1.4.19
- gnupg Libgcrypt: before 1.6.3 — fixed in 1.6.3
How to fix
Upgrade to a fixed version: GnuPG 1.4.19; gnupg Libgcrypt 1.6.3. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2015/dsa-3184
- http://www.debian.org/security/2015/dsa-3185
- https://ieeexplore.ieee.org/document/7163050
- https://lists.gnupg.org/pipermail/gnupg-announce/2015q1/000363.html
- https://lists.gnupg.org/pipermail/gnupg-announce/2015q1/000364.html
- http://www.debian.org/security/2015/dsa-3184
- http://www.debian.org/security/2015/dsa-3185
- https://ieeexplore.ieee.org/document/7163050
- https://lists.gnupg.org/pipermail/gnupg-announce/2015q1/000363.html
- https://lists.gnupg.org/pipermail/gnupg-announce/2015q1/000364.html
Get alerted when CVE-2015-0837 or the next vulnerability affects your stack