What’s Vulnerable › Vulnerabilities
CVE-2015-0841
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-09 · updated 2026-06-17
- Weakness: CWE-193
Description
Off-by-one error in the readBuf function in listener.cpp in libcapsinetwork and monopd before 0.9.8, allows remote attackers to cause a denial of service (crash) via a long line.
Affected products
- monopd: before 0.9.8 — fixed in 0.9.8
How to fix
Upgrade to a fixed version: monopd 0.9.8. Check the vendor advisory for mitigations.
References
- http://gtkatlantic.gradator.net/oldnews.html
- http://www.openwall.com/lists/oss-security/2015/03/23/20
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=781043
- https://security.gentoo.org/glsa/201507-12
- http://gtkatlantic.gradator.net/oldnews.html
- http://www.openwall.com/lists/oss-security/2015/03/23/20
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=781043
- https://security.gentoo.org/glsa/201507-12
Get alerted when CVE-2015-0841 or the next vulnerability affects your stack