What’s Vulnerable › Vulnerabilities
CVE-2015-10001: WP-Stats < 2.5.2 - CSRF to Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-01 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP-Stats WordPress plugin before 2.52 does not have CSRF check when saving its settings, and did not escape some of them when outputting them, allowing attacker to make logged in high privilege users change them and set Cross-Site Scripting payloads
Affected products
- WP-Stats: before 2.52 — fixed in 2.52
How to fix
Upgrade to a fixed version: WP-Stats 2.52. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f5c3dfea-7203-4a98-88ff-aa6a24d03734
- https://www.openwall.com/lists/oss-security/2015/06/17/6
- https://wpscan.com/vulnerability/f5c3dfea-7203-4a98-88ff-aa6a24d03734
- https://www.openwall.com/lists/oss-security/2015/06/17/6
Get alerted when CVE-2015-10001 or the next vulnerability affects your stack