What’s Vulnerable › Vulnerabilities
CVE-2015-10009: nterchange code_caller_controller.php getContent code injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-02 · updated 2026-06-17
- Weakness: CWE-94
Description
A vulnerability was found in nterchange up to 4.1.0. It has been rated as critical. This issue affects the function getContent of the file app/controllers/code_caller_controller.php. The manipulation of the argument q with the input %5C%27%29;phpinfo%28%29;/* leads to code injection. The exploit has been disclosed to the public and may be used. Upgrading to version 4.1.1 is able to address this issue. The patch is named fba7d89176fba8fe289edd58835fe45080797d99. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217187.
Affected products
- nterchange: before 4.1.1 — fixed in 4.1.1
How to fix
Upgrade to a fixed version: nterchange 4.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/nonfiction/nterchange_backend/commit/fba7d89176fba8fe289edd58835fe45080797d99
- https://github.com/nonfiction/nterchange_backend/releases/tag/4.1.1
- https://vuldb.com/?ctiid.217187
- https://vuldb.com/?id.217187
- https://github.com/nonfiction/nterchange_backend/commit/fba7d89176fba8fe289edd58835fe45080797d99
- https://github.com/nonfiction/nterchange_backend/releases/tag/4.1.1
- https://vuldb.com/?ctiid.217187
- https://vuldb.com/?id.217187
Get alerted when CVE-2015-10009 or the next vulnerability affects your stack