What’s Vulnerable › Vulnerabilities
CVE-2015-10013: WebDevStudios taxonomy-switcher Plugin taxonomy-switcher.php taxonomy_switcher_init cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-05 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in WebDevStudios taxonomy-switcher Plugin up to 1.0.3 on WordPress. It has been classified as problematic. Affected is the function taxonomy_switcher_init of the file taxonomy-switcher.php. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.0.4 is able to address this issue. It is recommended to upgrade the affected component. VDB-217446 is the identifier assigned to this vulnerability.
Affected products
- WebDevStudios taxonomy-switcher Plugin: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: WebDevStudios taxonomy-switcher Plugin 1.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/WebDevStudios/taxonomy-switcher/commit/e1a0d99f936e7427b31e210c67aeb4833d804099
- https://github.com/WebDevStudios/taxonomy-switcher/releases/tag/1.0.4
- https://vuldb.com/?ctiid.217446
- https://vuldb.com/?id.217446
- https://github.com/WebDevStudios/taxonomy-switcher/commit/e1a0d99f936e7427b31e210c67aeb4833d804099
- https://github.com/WebDevStudios/taxonomy-switcher/releases/tag/1.0.4
- https://vuldb.com/?ctiid.217446
- https://vuldb.com/?id.217446
Get alerted when CVE-2015-10013 or the next vulnerability affects your stack