What’s Vulnerable › Vulnerabilities
CVE-2015-10030: SUKOHI Surpass Surpass.php pathname traversal
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-08 · updated 2026-06-17
- Weakness: CWE-21
Description
A vulnerability has been found in SUKOHI Surpass and classified as critical. This vulnerability affects unknown code of the file src/Sukohi/Surpass/Surpass.php. The manipulation of the argument dir leads to pathname traversal. Upgrading to version 1.0.0 is able to address this issue. The patch is identified as d22337d453a2a14194cdb02bf12cdf9d9f827aa7. It is recommended to upgrade the affected component. VDB-217642 is the identifier assigned to this vulnerability.
Affected products
- SUKOHI Surpass: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: SUKOHI Surpass 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/SUKOHI/Surpass/commit/d22337d453a2a14194cdb02bf12cdf9d9f827aa7
- https://github.com/SUKOHI/Surpass/releases/tag/1.0.0
- https://vuldb.com/?ctiid.217642
- https://vuldb.com/?id.217642
- https://github.com/SUKOHI/Surpass/commit/d22337d453a2a14194cdb02bf12cdf9d9f827aa7
- https://github.com/SUKOHI/Surpass/releases/tag/1.0.0
- https://vuldb.com/?ctiid.217642
- https://vuldb.com/?id.217642
Get alerted when CVE-2015-10030 or the next vulnerability affects your stack