What’s Vulnerable › Vulnerabilities
CVE-2015-1007
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-25 · updated 2026-06-17
- Weakness: CWE-121
Description
A specially crafted configuration file could be used to cause a stack-based buffer overflow condition in the OPCTest.exe, which may allow remote code execution on Opto 22 PAC Project Professional versions prior to R9.4008, PAC Project Basic versions prior to R9.4008, PAC Display Basic versions prior to R9.4g, PAC Display Professional versions prior to R9.4g, OptoOPCServer version R9.4c and prior that were installed by PAC Project installer, versions prior to R9.4008, and OptoDataLink version R9.4d and prior that were installed by PAC Project installer, versions prior to R9.4008. Opto 22 suggests upgrading to the new product version as soon as possible.
Affected products
- Opto 22 OptoDataLink: through r9.4d
- Opto 22 OptoOPCServer: through r9.4c
- Opto22 Pac Display: before r9.4g — fixed in r9.4g
- Opto22 Pac Project: before r9.4008 — fixed in r9.4008
How to fix
Upgrade to a fixed version: Opto22 Pac Display r9.4g; Opto22 Pac Project r9.4008. Check the vendor advisory for mitigations.
References
- https://ics-cert.us-cert.gov/advisories/ICSA-15-120-01
- https://ics-cert.us-cert.gov/advisories/ICSA-15-120-01
Get alerted when CVE-2015-1007 or the next vulnerability affects your stack