What’s Vulnerable › Vulnerabilities
CVE-2015-10077: webbuilders-group silverstripe-kapost-bridge KapostService.php getPreview sql injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-10 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability was found in webbuilders-group silverstripe-kapost-bridge 0.3.3. It has been declared as critical. Affected by this vulnerability is the function index/getPreview of the file code/control/KapostService.php. The manipulation leads to sql injection. The attack can be launched remotely. Upgrading to version 0.4.0 is able to address this issue. The patch is named 2e14b0fd0ea35034f90890f364b130fb4645ff35. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220471.
Affected products
- webbuilders-group silverstripe-kapost-bridge: before 0.4.0 — fixed in 0.4.0
How to fix
Upgrade to a fixed version: webbuilders-group silverstripe-kapost-bridge 0.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/webbuilders-group/silverstripe-kapost-bridge/commit/2e14b0fd0ea35034f90890f364b130fb4645ff35
- https://github.com/webbuilders-group/silverstripe-kapost-bridge/releases/tag/0.4.0
- https://vuldb.com/?ctiid.220471
- https://vuldb.com/?id.220471
- https://github.com/webbuilders-group/silverstripe-kapost-bridge/commit/2e14b0fd0ea35034f90890f364b130fb4645ff35
- https://github.com/webbuilders-group/silverstripe-kapost-bridge/releases/tag/0.4.0
- https://vuldb.com/?ctiid.220471
- https://vuldb.com/?id.220471
Get alerted when CVE-2015-10077 or the next vulnerability affects your stack