What’s Vulnerable › Vulnerabilities
CVE-2015-10094: Fastly Plugin api.php post cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-06 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in Fastly Plugin up to 0.97 on WordPress. It has been rated as problematic. Affected by this issue is the function post of the file lib/api.php. The manipulation of the argument url leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.98 is able to address this issue. The patch is identified as d7fe42538f4d4af500e3af9678b6b06fba731656. It is recommended to upgrade the affected component. VDB-222326 is the identifier assigned to this vulnerability.
Affected products
- Fastly: before 0.98 — fixed in 0.98
How to fix
Upgrade to a fixed version: Fastly 0.98. Check the vendor advisory for mitigations.
References
- https://github.com/wp-plugins/fastly/commit/d7fe42538f4d4af500e3af9678b6b06fba731656
- https://github.com/wp-plugins/fastly/releases/tag/0.98
- https://vuldb.com/?ctiid.222326
- https://vuldb.com/?id.222326
- https://github.com/wp-plugins/fastly/commit/d7fe42538f4d4af500e3af9678b6b06fba731656
- https://github.com/wp-plugins/fastly/releases/tag/0.98
- https://vuldb.com/?ctiid.222326
- https://vuldb.com/?id.222326
Get alerted when CVE-2015-10094 or the next vulnerability affects your stack