What’s Vulnerable › Vulnerabilities
CVE-2015-10101: Google Analytics Top Content Widget Plugin class-tgm-plugin-activation.php cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-15 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability classified as problematic was found in Google Analytics Top Content Widget Plugin up to 1.5.6 on WordPress. Affected by this vulnerability is an unknown functionality of the file class-tgm-plugin-activation.php. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.5.7 is able to address this issue. The identifier of the patch is 25bb1dea113716200a6f0f3135801d84a7a65540. It is recommended to upgrade the affected component. The identifier VDB-226117 was assigned to this vulnerability.
Affected products
- Google Analytics Top Content Widget Plugin: before 1.5.7 — fixed in 1.5.7
How to fix
Upgrade to a fixed version: Google Analytics Top Content Widget Plugin 1.5.7. Check the vendor advisory for mitigations.
References
- https://github.com/wp-plugins/google-analytics-top-posts-widget/commit/25bb1dea113716200a6f0f3135801d84a7a65540
- https://vuldb.com/?ctiid.226117
- https://vuldb.com/?id.226117
- https://github.com/wp-plugins/google-analytics-top-posts-widget/commit/25bb1dea113716200a6f0f3135801d84a7a65540
- https://vuldb.com/?ctiid.226117
- https://vuldb.com/?id.226117
Get alerted when CVE-2015-10101 or the next vulnerability affects your stack