What’s Vulnerable › Vulnerabilities
CVE-2015-10105: IP Blacklist Cloud Plugin CSV File Import ip_blacklist_cloud.php valid_js_identifier path traversal
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-01 · updated 2026-06-17
- Weakness: CWE-22
Description
A vulnerability, which was classified as critical, was found in IP Blacklist Cloud Plugin up to 3.42 on WordPress. This affects the function valid_js_identifier of the file ip_blacklist_cloud.php of the component CSV File Import. The manipulation of the argument filename leads to path traversal. It is possible to initiate the attack remotely. Upgrading to version 3.43 is able to address this issue. The identifier of the patch is 6e6fe8c6fda7cbc252eef083105e08d759c07312. It is recommended to upgrade the affected component. The identifier VDB-227757 was assigned to this vulnerability.
Affected products
- Adeel Ahmed IP Blacklist Cloud: through 3.42
References
- https://github.com/wp-plugins/ip-blacklist-cloud/commit/6e6fe8c6fda7cbc252eef083105e08d759c07312
- https://github.com/wp-plugins/ip-blacklist-cloud/releases/tag/3.43
- https://vuldb.com/?ctiid.227757
- https://vuldb.com/?id.227757
- https://github.com/wp-plugins/ip-blacklist-cloud/commit/6e6fe8c6fda7cbc252eef083105e08d759c07312
- https://github.com/wp-plugins/ip-blacklist-cloud/releases/tag/3.43
- https://vuldb.com/?ctiid.227757
- https://vuldb.com/?id.227757
Get alerted when CVE-2015-10105 or the next vulnerability affects your stack