What’s Vulnerable › Vulnerabilities
CVE-2015-10110: ruddernation TinyChat Room Spy Plugin room-spy.php wp_show_room_spy cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-02 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability classified as problematic was found in ruddernation TinyChat Room Spy Plugin up to 1.2.8 on WordPress. This vulnerability affects the function wp_show_room_spy of the file room-spy.php. The manipulation of the argument room leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.2.9 is able to address this issue. The name of the patch is ab72627a963d61fb3bc31018e3855b08dc94a979. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-230392.
Affected products
- ruddernation TinyChat Room Spy Plugin: before 1.2.9 — fixed in 1.2.9
How to fix
Upgrade to a fixed version: ruddernation TinyChat Room Spy Plugin 1.2.9. Check the vendor advisory for mitigations.
References
- https://github.com/wp-plugins/tinychat-roomspy/commit/ab72627a963d61fb3bc31018e3855b08dc94a979
- https://vuldb.com/?ctiid.230392
- https://vuldb.com/?id.230392
- https://github.com/wp-plugins/tinychat-roomspy/commit/ab72627a963d61fb3bc31018e3855b08dc94a979
- https://vuldb.com/?ctiid.230392
- https://vuldb.com/?id.230392
Get alerted when CVE-2015-10110 or the next vulnerability affects your stack