What’s Vulnerable › Vulnerabilities
CVE-2015-10119: View All Posts Page Plugin view-all-posts-pages.php action_admin_notices_activation cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-10 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability, which was classified as problematic, has been found in View All Posts Page Plugin up to 0.9.0 on WordPress. This issue affects the function action_admin_notices_activation of the file view-all-posts-pages.php. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 0.9.1 is able to address this issue. The patch is named bf914f3a59063fa4df8fd4925ae18a5d852396d7. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-233363.
Affected products
- View All Posts Page Plugin: through 0.9.4
References
- https://github.com/wp-plugins/view-all-posts-pages/commit/bf914f3a59063fa4df8fd4925ae18a5d852396d7
- https://vuldb.com/?ctiid.233363
- https://vuldb.com/?id.233363
- https://github.com/wp-plugins/view-all-posts-pages/commit/bf914f3a59063fa4df8fd4925ae18a5d852396d7
- https://vuldb.com/?ctiid.233363
- https://vuldb.com/?id.233363
Get alerted when CVE-2015-10119 or the next vulnerability affects your stack