What’s Vulnerable › Vulnerabilities
CVE-2015-10128: rt-prettyphoto Plugin rt-prettyphoto.php royal_prettyphoto_plugin_links cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-02 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in rt-prettyphoto Plugin up to 1.2 on WordPress and classified as problematic. Affected by this issue is the function royal_prettyphoto_plugin_links of the file rt-prettyphoto.php. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.3 is able to address this issue. The patch is identified as 0d3d38cfa487481b66869e4212df1cefc281ecb7. It is recommended to upgrade the affected component. VDB-249422 is the identifier assigned to this vulnerability.
Affected products
- rt-prettyphoto Plugin: before 1.3 — fixed in 1.3
How to fix
Upgrade to a fixed version: rt-prettyphoto Plugin 1.3. Check the vendor advisory for mitigations.
References
- https://github.com/wp-plugins/rt-prettyphoto/commit/0d3d38cfa487481b66869e4212df1cefc281ecb7
- https://vuldb.com/?ctiid.249422
- https://vuldb.com/?id.249422
- https://github.com/wp-plugins/rt-prettyphoto/commit/0d3d38cfa487481b66869e4212df1cefc281ecb7
- https://vuldb.com/?ctiid.249422
- https://vuldb.com/?id.249422
Get alerted when CVE-2015-10128 or the next vulnerability affects your stack