What’s Vulnerable › Vulnerabilities
CVE-2015-10135: WPshop 2 – E-Commerce < 1.3.9.6 - Arbitrary File Upload
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-19 · updated 2026-06-17
- Weakness: CWE-434
Description
The WPshop 2 – E-Commerce plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the ajaxUpload function in versions before 1.3.9.6. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected sites server which may make remote code execution possible.
Affected products
- eoxia WPshop 2 – E-Commerce: before 1.3.9.6 — fixed in 1.3.9.6
How to fix
Upgrade to a fixed version: eoxia WPshop 2 – E-Commerce 1.3.9.6. Check the vendor advisory for mitigations.
References
- https://g0blin.co.uk/g0blin-00036/
- https://github.com/espreto/wpsploit/blob/master/modules/exploits/unix/webapp/wp_wpshop_ecommerce_file_upload.rb
- https://plugins.trac.wordpress.org/changeset/1103406
- https://wordpress.org/plugins/wpshop/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/32e8224d-a653-48d7-a3f4-338fc0c1dc77?source=cve
Get alerted when CVE-2015-10135 or the next vulnerability affects your stack