What’s Vulnerable › Vulnerabilities
CVE-2015-1209
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-02-06 · updated 2026-06-17
- Weakness: CWE-416
Description
Use-after-free vulnerability in the VisibleSelection::nonBoundaryShadowTreeRootNode function in core/editing/VisibleSelection.cpp in the DOM implementation in Blink, as used in Google Chrome before 40.0.2214.111 on Windows, OS X, and Linux and before 40.0.2214.109 on Android, allows remote attackers to cause a denial of service or possibly have unspecified other impact via crafted JavaScript code that triggers improper handling of a shadow-root anchor.
Affected products
- Canonical Ubuntu Linux: 14.04, 14.10
- Google Chrome: before 40.0.2214.109; before 40.0.2214.111 — fixed in 40.0.2214.109, 40.0.2214.111
- Opensuse: 13.1, 13.2
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Eus: 6.6
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Server Aus: 6.6
- RedHat Enterprise Linux Workstation: 6.0
How to fix
Upgrade to a fixed version: Google Chrome 40.0.2214.109, 40.0.2214.111. Check the vendor advisory for mitigations.
References
- http://googlechromereleases.blogspot.com/2015/02/chrome-for-android-update.html
- http://googlechromereleases.blogspot.com/2015/02/stable-channel-update.html
- http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00005.html
- http://rhn.redhat.com/errata/RHSA-2015-0163.html
- http://secunia.com/advisories/62670
- http://secunia.com/advisories/62818
- http://secunia.com/advisories/62917
- http://secunia.com/advisories/62925
- http://security.gentoo.org/glsa/glsa-201502-13.xml
- http://www.securityfocus.com/bid/72497
- http://www.securitytracker.com/id/1031709
- http://www.ubuntu.com/usn/USN-2495-1
Get alerted when CVE-2015-1209 or the next vulnerability affects your stack