What’s Vulnerable › Vulnerabilities
CVE-2015-1341: Apport privilege escalation through Python module imports
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-22 · updated 2026-06-17
- Weakness: CWE-264
Description
Any Python module in sys.path can be imported if the command line of the process triggering the coredump is Python and the first argument is -m in Apport before 2.19.2 function _python_module_path.
Affected products
- Canonical apport: before 2.19.2 — fixed in 2.19.2
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04, 15.10
How to fix
Upgrade to a fixed version: Canonical apport 2.19.2. Check the vendor advisory for mitigations.
References
- https://launchpad.net/apport/trunk/2.19.2
- https://usn.ubuntu.com/2782-1/
- https://launchpad.net/apport/trunk/2.19.2
- https://usn.ubuntu.com/2782-1/
Get alerted when CVE-2015-1341 or the next vulnerability affects your stack