What’s Vulnerable › Vulnerabilities
CVE-2015-1394
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in the Photo Gallery plugin before 1.2.11 for WordPress allow remote authenticated users to inject arbitrary web script or HTML via the (1) sort_by, (2) sort_order, (3) items_view, (4) dir, (5) clipboard_task, (6) clipboard_files, (7) clipboard_src, or (8) clipboard_dest parameters in an addImages action to wp-admin/admin-ajax.php.
Affected products
- 10web Photo Gallery by 10Web – Mobile-Friendly Image Gallery: before 1.2.11 — fixed in 1.2.11
How to fix
Upgrade to a fixed version: 10web Photo Gallery by 10Web – Mobile-Friendly Image Gallery 1.2.11. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/archive/1/archive/1/534568/100/0/threaded
- https://plugins.trac.wordpress.org/changeset/1073334/
- https://plugins.trac.wordpress.org/changeset/1076678/photo-gallery
- https://seclists.org/bugtraq/2015/Jan/140
- https://wordpress.org/plugins/photo-gallery/changelog/
- http://www.securityfocus.com/archive/1/archive/1/534568/100/0/threaded
- https://plugins.trac.wordpress.org/changeset/1073334/
- https://plugins.trac.wordpress.org/changeset/1076678/photo-gallery
- https://seclists.org/bugtraq/2015/Jan/140
- https://wordpress.org/plugins/photo-gallery/changelog/
Get alerted when CVE-2015-1394 or the next vulnerability affects your stack