What’s Vulnerable › Vulnerabilities
CVE-2015-1396
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-25 · updated 2026-06-17
- Weakness: CWE-22
Description
A Directory Traversal vulnerability exists in the GNU patch before 2.7.4. A remote attacker can write to arbitrary files via a symlink attack in a patch file. NOTE: this issue exists because of an incomplete fix for CVE-2015-1196.
Affected products
- Debian Linux: 8.0, 9.0, 10.0, 11.0
- GNU patch: before 2.7.4 — fixed in 2.7.4
How to fix
Upgrade to a fixed version: GNU patch 2.7.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2015/01/27/29
- http://www.openwall.com/lists/oss-security/2015/01/27/29
- http://www.openwall.com/lists/oss-security/2015/01/27/29
- http://www.openwall.com/lists/oss-security/2015/01/27/29
- http://www.securityfocus.com/bid/75358
- http://www.securityfocus.com/bid/75358
- http://www.securityfocus.com/bid/75358
- http://www.securityfocus.com/bid/75358
- http://www.ubuntu.com/usn/USN-2651-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1186764
- http://www.openwall.com/lists/oss-security/2015/01/27/29
- http://www.openwall.com/lists/oss-security/2015/01/27/29
Get alerted when CVE-2015-1396 or the next vulnerability affects your stack