What’s Vulnerable › Vulnerabilities

CVE-2015-1421

Description

Use-after-free vulnerability in the sctp_assoc_update function in net/sctp/associola.c in the Linux kernel before 3.18.8 allows remote attackers to cause a denial of service (slab corruption and panic) or possibly have unspecified other impact by triggering an INIT collision that leads to improper handling of shared-key data.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.10.70, 3.12.38, 3.14.34, 3.16.35. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-1421 or the next vulnerability affects your stack