What’s Vulnerable › Vulnerabilities

CVE-2015-1427: Elasticsearch Groovy Scripting Engine Remote Code Execution Vulnerability

Description

The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows remote attackers to bypass the sandbox protection mechanism and execute arbitrary shell commands via a crafted script.

Affected products

How to fix

Upgrade to a fixed version: Elasticsearch 1.3.8, 1.4.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-1427 or the next vulnerability affects your stack