What’s Vulnerable › Vulnerabilities
CVE-2015-1465
- Severity: high (CVSS 7.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-04-05 · updated 2026-06-17
- Weakness: CWE-17
Description
The IPv4 implementation in the Linux kernel before 3.18.8 does not properly consider the length of the Read-Copy Update (RCU) grace period for redirecting lookups in the absence of caching, which allows remote attackers to cause a denial of service (memory consumption or system crash) via a flood of packets.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 14.10
- Linux kernel: from 3.10.50 before 3.10.70; from 3.12.26 before 3.12.38; from 3.14.14 before 3.14.34; from 3.15.7 before 3.16.35; from 3.17 before 3.18.8 — fixed in 3.10.70, 3.12.38, 3.14.34, 3.16.35, 3.18.8
How to fix
Upgrade to a fixed version: Linux kernel 3.10.70, 3.12.38, 3.14.34, 3.16.35. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=df4d92549f23e1c037e83323aff58a21b3de7fe0
- http://lists.opensuse.org/opensuse-security-announce/2015-08/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00009.html
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.8
- http://www.openwall.com/lists/oss-security/2015/02/03/13
- http://www.securityfocus.com/bid/72435
- http://www.securitytracker.com/id/1036763
- http://www.ubuntu.com/usn/USN-2545-1
- http://www.ubuntu.com/usn/USN-2546-1
- http://www.ubuntu.com/usn/USN-2562-1
- http://www.ubuntu.com/usn/USN-2563-1
Get alerted when CVE-2015-1465 or the next vulnerability affects your stack