What’s Vulnerable › Vulnerabilities
CVE-2015-1530
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-24 · updated 2026-06-17
- Weakness: CWE-190
Description
media/libmedia/IAudioPolicyService.cpp in Android before 5.1 allows attackers to execute arbitrary code with media_server privileges or cause a denial of service (integer overflow) via a crafted application that provides an invalid array size.
Affected products
- Android: before 5.1 — fixed in 5.1
How to fix
Upgrade to a fixed version: Android 5.1. Check the vendor advisory for mitigations.
References
- https://android.googlesource.com/platform/frameworks/av/+/74adca9%5E%21/
- https://android.googlesource.com/platform/frameworks/av/+/74adca9%5E%21/
Get alerted when CVE-2015-1530 or the next vulnerability affects your stack