What’s Vulnerable › Vulnerabilities
CVE-2015-1607
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-20 · updated 2026-06-17
- Weakness: CWE-20
Description
kbx/keybox-search.c in GnuPG before 1.4.19, 2.0.x before 2.0.27, and 2.1.x before 2.1.2 does not properly handle bitwise left-shifts, which allows remote attackers to cause a denial of service (invalid read operation) via a crafted keyring file, related to sign extensions and "memcpy with overlapping ranges."
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 14.04, 14.10
- GnuPG: before 1.4.19; from 2.0 before 2.0.27; from 2.1.0 before 2.1.2 — fixed in 1.4.19, 2.0.27, 2.1.2
How to fix
Upgrade to a fixed version: GnuPG 1.4.19, 2.0.27, 2.1.2. Check the vendor advisory for mitigations.
References
- http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git%3Ba=commit%3Bh=2183683bd633818dd031b090b5530951de76f392
- http://www.openwall.com/lists/oss-security/2015/02/13/14
- http://www.openwall.com/lists/oss-security/2015/02/14/6
- http://www.securityfocus.com/bid/72610
- http://www.ubuntu.com/usn/usn-2554-1/
- https://blog.fuzzing-project.org/5-Multiple-issues-in-GnuPG-found-through-keyring-fuzzing-TFPA-0012015.html
- https://lists.gnupg.org/pipermail/gnupg-announce/2015q1/000361.html
- https://lists.gnupg.org/pipermail/gnupg-announce/2015q1/000362.html
- https://lists.gnupg.org/pipermail/gnupg-announce/2015q1/000363.html
- http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git%3Ba=commit%3Bh=2183683bd633818dd031b090b5530951de76f392
- http://www.openwall.com/lists/oss-security/2015/02/13/14
- http://www.openwall.com/lists/oss-security/2015/02/14/6
Get alerted when CVE-2015-1607 or the next vulnerability affects your stack