What’s Vulnerable › Vulnerabilities

CVE-2015-1855

Description

verify_certificate_identity in the OpenSSL extension in Ruby before 2.0.0 patchlevel 645, 2.1.x before 2.1.6, and 2.2.x before 2.2.2 does not properly validate hostnames, which allows remote attackers to spoof servers via vectors related to (1) multiple wildcards, (1) wildcards in IDNA names, (3) case sensitivity, and (4) non-ASCII characters.

Affected products

How to fix

Upgrade to a fixed version: Puppet Enterprise 3.8.0; Ruby 2.1.6, 2.2.2; ruby-lang Trunk 50292. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-1855 or the next vulnerability affects your stack