What’s Vulnerable › Vulnerabilities
CVE-2015-1931
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-29 · updated 2026-06-17
- Weakness: CWE-312
Description
IBM Java Security Components in IBM SDK, Java Technology Edition 8 before SR1 FP10, 7 R1 before SR3 FP10, 7 before SR9 FP10, 6 R1 before SR8 FP7, 6 before SR16 FP7, and 5.0 before SR16 FP13 stores plaintext information in memory dumps, which allows local users to obtain sensitive information by reading a file.
Affected products
- IBM SDK, Java Technology Edition: from 5.0.0.0 before 5.0.16.13; from 6.0.0.0 before 6.0.16.7; from 6.1.0.0 before 6.1.8.7; from 7.0.0.0 before 7.0.9.10; from 7.1.0.0 before 7.1.3.10; from 8.0.0.0 before 8.0.1.10 — fixed in 5.0.16.13, 6.0.16.7, 6.1.8.7, 7.0.9.10, 7.1.3.10, 8.0.1.10
- RedHat Enterprise Linux Desktop: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Eus: 6.7, 7.1, 7.2, 7.3, 7.4, 7.5
- RedHat Enterprise Linux Server: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Workstation: 5.0, 6.0, 7.0
- Red Hat Satellite 6: 5.6, 5.7
- SUSE Linux Enterprise Server: 11-sp1, 11-sp2, 11-sp3, 11-sp4
- SUSE Linux Enterprise Software Development Kit: 11-sp3, 11-sp4
How to fix
Upgrade to a fixed version: IBM SDK, Java Technology Edition 5.0.16.13, 6.0.16.7, 6.1.8.7, 7.0.9.10. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00051.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00014.html
- http://rhn.redhat.com/errata/RHSA-2015-1485.html
- http://rhn.redhat.com/errata/RHSA-2015-1486.html
- http://rhn.redhat.com/errata/RHSA-2015-1488.html
- http://rhn.redhat.com/errata/RHSA-2015-1544.html
- http://rhn.redhat.com/errata/RHSA-2015-1604.html
- http://www-01.ibm.com/support/docview.wss?uid=swg1IV75182
- http://www-01.ibm.com/support/docview.wss?uid=swg21962302
- http://www.securityfocus.com/bid/75985
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00051.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00014.html
Get alerted when CVE-2015-1931 or the next vulnerability affects your stack