What’s Vulnerable › Vulnerabilities
CVE-2015-1957
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-10 · updated 2026-06-17
- Weakness: CWE-200
Description
IBM WebSphere MQ 7.5.x before 7.5.0.6 and 8.0.x before 8.0.0.3 allows remote authenticated users to obtain sensitive information via a man-in-the-middle attack, related to duplication of message data in cleartext outside the protected payload. IBM X-Force ID: 103482.
Affected products
- IBM Corporation WebSphere MQ: from 7.5 before 7.5.0.6; from 8.0 before 8.0.0.3 — fixed in 7.5.0.6, 8.0.0.3
How to fix
Upgrade to a fixed version: IBM Corporation WebSphere MQ 7.5.0.6, 8.0.0.3. Check the vendor advisory for mitigations.
References
- http://www-01.ibm.com/support/docview.wss?uid=swg21960506
- https://exchange.xforce.ibmcloud.com/vulnerabilities/103482
- http://www-01.ibm.com/support/docview.wss?uid=swg21960506
- https://exchange.xforce.ibmcloud.com/vulnerabilities/103482
Get alerted when CVE-2015-1957 or the next vulnerability affects your stack