What’s Vulnerable › Vulnerabilities
CVE-2015-20001
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-11 · updated 2026-06-17
- Weakness: CWE-119
Description
In the standard library in Rust before 1.2.0, BinaryHeap is not panic-safe. The binary heap is left in an inconsistent state when the comparison of generic elements inside sift_up or sift_down_range panics. This bug leads to a drop of zeroed memory as an arbitrary type, which can result in a memory safety violation.
Affected products
- rust-lang rust: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: rust-lang rust 1.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/rust-lang/rust/issues/25842
- https://github.com/rust-lang/rust/pull/25856
- https://github.com/rust-lang/rust/issues/25842
- https://github.com/rust-lang/rust/pull/25856
Get alerted when CVE-2015-20001 or the next vulnerability affects your stack