What’s Vulnerable › Vulnerabilities
CVE-2015-2001
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-29 · updated 2026-06-17
- Weakness: CWE-118
Description
The MetaIO SDK before 6.0.2.1 for Android might allow attackers to execute arbitrary code by leveraging a finalize method in a Serializable class that improperly passes an attacker-controlled pointer to a native function.
Affected products
- Metaio Sdk: before 6.0.2.1 — fixed in 6.0.2.1
How to fix
Upgrade to a fixed version: Metaio Sdk 6.0.2.1. Check the vendor advisory for mitigations.
References
- https://alephsecurity.com/vulns/aleph-2015002
- https://www.usenix.org/system/files/conference/woot15/woot15-paper-peles.pdf
- https://alephsecurity.com/vulns/aleph-2015002
- https://www.usenix.org/system/files/conference/woot15/woot15-paper-peles.pdf
Get alerted when CVE-2015-2001 or the next vulnerability affects your stack