What’s Vulnerable › Vulnerabilities
CVE-2015-20019: Content text slider on post < 6.9 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Content text slider on post WordPress plugin before 6.9 does not sanitise and escape the Title and Message/Content settings, which could lead to Cross-Site Scripting issues
Affected products
- Content text slider on post: before 6.9 — fixed in 6.9
How to fix
Upgrade to a fixed version: Content text slider on post 6.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/1393044/content-text-slider-on-post
- https://seclists.org/bugtraq/2015/Dec/124
- https://wpscan.com/vulnerability/4f92b211-e09c-4ed0-bc98-27e0b51b1f86
- https://plugins.trac.wordpress.org/changeset/1393044/content-text-slider-on-post
- https://seclists.org/bugtraq/2015/Dec/124
- https://wpscan.com/vulnerability/4f92b211-e09c-4ed0-bc98-27e0b51b1f86
Get alerted when CVE-2015-20019 or the next vulnerability affects your stack