What’s Vulnerable › Vulnerabilities
CVE-2015-2002
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-29 · updated 2026-06-17
- Weakness: CWE-118
Description
The ESRI ArcGis Runtime SDK before 10.2.6-2 for Android might allow attackers to execute arbitrary code by leveraging a finalize method in a Serializable class that improperly passes an attacker-controlled pointer to a native function.
Affected products
- Esri Arcgisruntime Sdk: before 10.2.6-2 — fixed in 10.2.6-2
How to fix
Upgrade to a fixed version: Esri Arcgisruntime Sdk 10.2.6-2. Check the vendor advisory for mitigations.
References
- https://alephsecurity.com/vulns/aleph-2015003
- https://www.usenix.org/system/files/conference/woot15/woot15-paper-peles.pdf
- https://alephsecurity.com/vulns/aleph-2015003
- https://www.usenix.org/system/files/conference/woot15/woot15-paper-peles.pdf
Get alerted when CVE-2015-2002 or the next vulnerability affects your stack