What’s Vulnerable › Vulnerabilities
CVE-2015-20108
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-27 · updated 2026-06-17
- Weakness: CWE-77
Description
xml_security.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used.
Affected products
- SAML-Toolkits ruby-saml: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: SAML-Toolkits ruby-saml 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/SAML-Toolkits/ruby-saml/commit/9853651b96b99653ea8627d757d46bfe62ab6448
- https://github.com/SAML-Toolkits/ruby-saml/compare/v0.9.2...v1.0.0
- https://github.com/SAML-Toolkits/ruby-saml/pull/225
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/OSVDB-124991.yml
- https://security.netapp.com/advisory/ntap-20230703-0003/
- https://github.com/SAML-Toolkits/ruby-saml/commit/9853651b96b99653ea8627d757d46bfe62ab6448
- https://github.com/SAML-Toolkits/ruby-saml/compare/v0.9.2...v1.0.0
- https://github.com/SAML-Toolkits/ruby-saml/pull/225
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/OSVDB-124991.yml
- https://security.netapp.com/advisory/ntap-20230703-0003/
Get alerted when CVE-2015-20108 or the next vulnerability affects your stack