What’s Vulnerable › Vulnerabilities
CVE-2015-20111
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-120
Description
miniupnp before 4c90b87, as used in Bitcoin Core before 0.12 and other products, lacks checks for snprintf return values, leading to a buffer overflow and significant data leak, a different vulnerability than CVE-2019-12107. In Bitcoin Core before 0.12, remote code execution was possible in conjunction with CVE-2015-6031 exploitation.
Affected products
- Bitcoin Core: before 0.12 — fixed in 0.12
How to fix
Upgrade to a fixed version: Bitcoin Core 0.12. Check the vendor advisory for mitigations.
References
- https://bitcoincore.org/en/2024/07/03/disclose_upnp_rce/
- https://en.bitcoin.it/wiki/Common_Vulnerabilities_and_Exposures
- https://github.com/miniupnp/miniupnp/commit/4c90b87ce3d2517097880279e8c3daa7731100e6
- https://github.com/miniupnp/miniupnp/pull/157
Get alerted when CVE-2015-20111 or the next vulnerability affects your stack