What’s Vulnerable › Vulnerabilities
CVE-2015-20123: Aspose Doc Exporter WordPress Plugin < 2.0 Path Traversal via aspose_doc_exporter_download.php
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-27
- Weakness: CWE-22
Description
Aspose Doc Exporter plugin for WordPress before 2.0 contains a path traversal vulnerability that allows unauthenticated attackers to download arbitrary files by passing unsanitized paths to readfile(). Attackers can send GET requests to aspose_doc_exporter_download.php with the 'file' parameter set to values like ../../../wp-config.php to retrieve database credentials. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-23.
Affected products
- Aspose Doc Exporter: from 1.0 before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: Aspose Doc Exporter 2.0. Check the vendor advisory for mitigations.
References
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/aspose-words-file-download.yaml
- https://packetstorm.news/files/id/131167/
- https://wordpress.org/plugins/aspose-doc-exporter/
- https://wpscan.com/vulnerability/043aa583-a81d-4565-bf65-83252b8f1f96
- https://www.exploit-db.com/exploits/36559
- https://www.vulncheck.com/advisories/aspose-doc-exporter-wordpress-plugin-2.0-path-traversal-via-aspose-doc-exporter-download-php
Get alerted when CVE-2015-20123 or the next vulnerability affects your stack