What’s Vulnerable › Vulnerabilities
CVE-2015-20124: Aspose Importer & Exporter WordPress Plugin < 3.0 Path Traversal via aspose_import_export_download.php
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-22
- Weakness: CWE-22
Description
Aspose Importer & Exporter plugin for WordPress before 3.0 contains a path traversal vulnerability that allows unauthenticated attackers to download arbitrary files via the unsanitized 'file' parameter. Attackers can send GET requests to aspose_import_export_download.php with traversal sequences like ../../../wp-config.php to read database credentials. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-20.
Affected products
- Aspose Importer & Exporter: from 1.0 before 3.0 — fixed in 3.0
How to fix
Upgrade to a fixed version: Aspose Importer & Exporter 3.0. Check the vendor advisory for mitigations.
References
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/aspose-ie-file-download.yaml
- https://packetstorm.news/files/id/131162/
- https://wordpress.org/plugins/aspose-importer-exporter/
- https://www.vulncheck.com/advisories/aspose-importer-exporter-wordpress-plugin-3.0-path-traversal-via-aspose-import-export-download-php
Get alerted when CVE-2015-20124 or the next vulnerability affects your stack