What’s Vulnerable › Vulnerabilities
CVE-2015-20125: Aspose PDF Exporter WordPress Plugin < 2.0 Path Traversal via aspose_pdf_exporter_download.php
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-28
- Weakness: CWE-22
Description
Aspose PDF Exporter plugin for WordPress before 2.0 contains a path traversal vulnerability that allows unauthenticated attackers to download files through the unsanitized 'file' parameter passed to readfile(). Attackers can send GET requests to aspose_pdf_exporter_download.php with traversal sequences like ../../../wp-config.php to retrieve WordPress database credentials. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.
Affected products
- Aspose PDF Exporter: from 1.0 before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: Aspose PDF Exporter 2.0. Check the vendor advisory for mitigations.
References
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/aspose-pdf-file-download.yaml
- https://packetstorm.news/files/id/131161/
- https://plugins.trac.wordpress.org/changeset/1127209/aspose-pdf-exporter
- https://wordpress.org/plugins/aspose-pdf-exporter/
- https://wpscan.com/vulnerability/51dd0b6b-ba90-47e2-ad80-56b3e122bfd4
- https://www.vulncheck.com/advisories/aspose-pdf-exporter-wordpress-plugin-2.0-path-traversal-via-aspose-pdf-exporter-download-php
Get alerted when CVE-2015-20125 or the next vulnerability affects your stack