What’s Vulnerable › Vulnerabilities
CVE-2015-2060
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-29 · updated 2026-06-17
- Weakness: CWE-22
Description
cabextract before 1.6 does not properly check for leading slashes when extracting files, which allows remote attackers to conduct absolute directory traversal attacks via a malformed UTF-8 character that is changed to a UTF-8 encoded slash.
Affected products
- Cabextract Project Cabextract: before 1.6 — fixed in 1.6
How to fix
Upgrade to a fixed version: Cabextract Project Cabextract 1.6. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2015-March/151145.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-March/151147.html
- http://www.cabextract.org.uk/
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:064
- http://www.openwall.com/lists/oss-security/2015/02/18/3
- http://www.openwall.com/lists/oss-security/2015/02/23/16
- http://www.openwall.com/lists/oss-security/2015/02/23/24
- http://lists.fedoraproject.org/pipermail/package-announce/2015-March/151145.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-March/151147.html
- http://www.cabextract.org.uk/
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:064
- http://www.openwall.com/lists/oss-security/2015/02/18/3
Get alerted when CVE-2015-2060 or the next vulnerability affects your stack