What’s Vulnerable › Vulnerabilities
CVE-2015-2101
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-02-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the Navigate bar in the Navigate module before 6.x-1.1 and 7.x-1.x before 7.x-1.1 for Drupal allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Affected products
- Impliedbydesign Navigate: from 6.x-1.0 before 6.x-1.1; from 7.x-1.0 before 7.x-1.1 — fixed in 6.x-1.1, 7.x-1.1
How to fix
Upgrade to a fixed version: Impliedbydesign Navigate 6.x-1.1, 7.x-1.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/72670
- https://www.drupal.org/node/2428503
- https://www.drupal.org/node/2428505
- https://www.drupal.org/node/2428815
- http://www.securityfocus.com/bid/72670
- https://www.drupal.org/node/2428503
- https://www.drupal.org/node/2428505
- https://www.drupal.org/node/2428815
Get alerted when CVE-2015-2101 or the next vulnerability affects your stack