What’s Vulnerable › Vulnerabilities

CVE-2015-2204

Description

Evergreen before 2.5.9, 2.6.x before 2.6.7, and 2.7.x before 2.7.4 allows remote attackers to bypass an intended access restriction and obtain sensitive information about org unit settings by leveraging failure of open-ils.actor.ou_setting.ancestor_default to enforce view_perm when no auth token is provided.

Affected products

How to fix

Upgrade to a fixed version: Evergreen-Ils Evergreen 2.5.9, 2.6.7, 2.7.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-2204 or the next vulnerability affects your stack