What’s Vulnerable › Vulnerabilities

CVE-2015-2301

Description

Use-after-free vulnerability in the phar_rename_archive function in phar_object.c in PHP before 5.5.22 and 5.6.x before 5.6.6 allows remote attackers to cause a denial of service or possibly have unspecified other impact via vectors that trigger an attempted renaming of a Phar archive to the name of an existing file.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.4.40, 5.5.22, 5.6.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-2301 or the next vulnerability affects your stack