What’s Vulnerable › Vulnerabilities

CVE-2015-2305

Description

Integer overflow in the regcomp implementation in the Henry Spencer BSD regex library (aka rxspencer) alpha3.8.g5 on 32-bit platforms, as used in NetBSD through 6.1.5 and other products, might allow context-dependent attackers to execute arbitrary code via a large regular expression that leads to a heap-based buffer overflow.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.4.39, 5.5.23, 5.6.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-2305 or the next vulnerability affects your stack