What’s Vulnerable › Vulnerabilities
CVE-2015-2325
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-14 · updated 2026-06-17
- Weakness: CWE-125
Description
The compile_branch function in PCRE before 8.37 allows context-dependent attackers to compile incorrect code, cause a denial of service (out-of-bounds heap read and crash), or possibly have other unspecified impact via a regular expression with a group containing a forward reference repeated a large number of times within a repeated outer group that has a zero minimum quantifier.
Affected products
- MariaDB: before 10.0.18 — fixed in 10.0.18
- Opensuse: 13.1, 13.2
- Pcre: before 8.37 — fixed in 8.37
- PHP: from 5.4.0 before 5.4.41; from 5.5.0 before 5.5.26; from 5.6.0 before 5.6.9 — fixed in 5.4.41, 5.5.26, 5.6.9
How to fix
Upgrade to a fixed version: MariaDB 10.0.18; Pcre 8.37; PHP 5.4.41, 5.5.26, 5.6.9. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2015-05/msg00014.html
- https://bugs.exim.org/show_bug.cgi?id=1591
- https://fortiguard.com/zeroday/FG-VD-15-015
- https://www.pcre.org/original/changelog.txt
- http://lists.opensuse.org/opensuse-updates/2015-05/msg00014.html
- https://bugs.exim.org/show_bug.cgi?id=1591
- https://fortiguard.com/zeroday/FG-VD-15-015
- https://www.pcre.org/original/changelog.txt
Get alerted when CVE-2015-2325 or the next vulnerability affects your stack