What’s Vulnerable › Vulnerabilities

CVE-2015-2326

Description

The pcre_compile2 function in PCRE before 8.37 allows context-dependent attackers to compile incorrect code and cause a denial of service (out-of-bounds read) via regular expression with a group containing both a forward referencing subroutine call and a recursive back reference, as demonstrated by "((?+1)(\1))/".

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.0.18; Pcre 8.37; PHP 5.4.41, 5.5.26, 5.6.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-2326 or the next vulnerability affects your stack